summaryrefslogtreecommitdiff
path: root/contrib/repo-conf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/repo-conf/configure.ac')
-rw-r--r--contrib/repo-conf/configure.ac42
1 files changed, 28 insertions, 14 deletions
diff --git a/contrib/repo-conf/configure.ac b/contrib/repo-conf/configure.ac
index ba2dab4453..abcc8b5b7b 100644
--- a/contrib/repo-conf/configure.ac
+++ b/contrib/repo-conf/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT([rtems-]_RTEMS_API[-repo-conf],[0.12],[http://www.rtems.org/bugzilla],
+AC_INIT([rtems-]_RTEMS_API[-repo-conf],[0.13],[http://www.rtems.org/bugzilla],
[rtems-]_RTEMS_API[-repo-conf])
RTEMS_VERSIONING
AC_CONFIG_SRCDIR([gpg])
@@ -10,22 +10,36 @@ AC_CONFIG_AUX_DIR([.])
AC_SUBST([RTEMS_API],[_RTEMS_API])
AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip 1.10])
-AC_ARG_ENABLE(os_subdir,AS_HELP_STRING(
-[--enable-os-subdir=<dir> ... os subdirectory]),
-[os_subdir="$enable_os_subdir"],
-[os_subdir="fedora/"])
-AC_SUBST([OS_SUBDIR],[$os_subdir])
+AC_ARG_ENABLE(osname,AS_HELP_STRING(
+[--enable-osname=<dir> ... os name]),
+[osname="$enable_osname"],
+[AC_MSG_ERROR([Missing --enable-osname=<name>"])
+])
-case "$os_subdir" in
-centos/ ) os_name="CentOS"
- apt_versdir="\$(VERSION)"
- yum_versdir="\"(apivers)";;
-fedora/ ) os_name="Fedora";;
-redhat/el ) os_name="CentOS";;
-suse/ ) os_name="openSUSE";;
-*) AC_MSG_ERROR([Invalid os-name])
+case $osname in
+centos-5* | redhat-el5* | fedora-[789]* | fedora-10* )
+ os_name="CentOS"
+ os_subdir="centos/"
+ yum_verdir="5"
+ apt_verdir="5"
+ ;;
+centos-4* | redhat-el4* | fedora-[56]* )
+ os_name="CentOS"
+ os_subdir="centos/"
+ yum_verdir="4"
+ apt_verdir="4"
+ ;;
+suse-*)
+ os_name="openSUSE"
+ os_subdir="suse/"
+ yum_verdir="\$\$releasever"
+ apt_verdir="\$\$(VERSION)"
;;
esac
+
+AC_SUBST([OS_SUBDIR],[$os_subdir])
+AC_SUBST([YUM_VERDIR],[$yum_verdir])
+AC_SUBST([APT_VERDIR],[$apt_verdir])
AC_SUBST([OS_NAME],[$os_name])
AC_CONFIG_FILES([Makefile])