summaryrefslogtreecommitdiff
path: root/cpukit/zlib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/zlib/CMakeLists.txt')
-rw-r--r--cpukit/zlib/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/cpukit/zlib/CMakeLists.txt b/cpukit/zlib/CMakeLists.txt
index a64fe0b2ca..7eefa49251 100644
--- a/cpukit/zlib/CMakeLists.txt
+++ b/cpukit/zlib/CMakeLists.txt
@@ -20,7 +20,7 @@ check_include_file(stddef.h HAVE_STDDEF_H)
#
# Check to see if we have large file support
#
-set(CMAKE_REQUIRED_DEFINITIONS -D_LARGEFILE64_SOURCE=1)
+set(CMAKE_REQUIRED_DEFINITIONS -D_LARGEFILE64_SOURCE)
# We add these other definitions here because CheckTypeSize.cmake
# in CMake 2.4.x does not automatically do so and we want
# compatibility with CMake 2.4.x.
@@ -35,7 +35,7 @@ if(HAVE_STDDEF_H)
endif()
check_type_size(off64_t OFF64_T)
if(HAVE_OFF64_T)
- add_definitions(-D_LARGEFILE64_SOURCE=1)
+ add_definitions(-D_LARGEFILE64_SOURCE)
endif()
set(CMAKE_REQUIRED_DEFINITIONS) # clear variable
@@ -52,6 +52,13 @@ endif()
#
check_include_file(unistd.h Z_HAVE_UNISTD_H)
+#
+# Check for errno.h
+check_include_file(errno.h HAVE_ERRNO_H)
+if(NOT HAVE_ERRNO_H)
+ add_definitions(-DNO_ERRNO_H)
+endif()
+
if(MSVC)
set(CMAKE_DEBUG_POSTFIX "d")
add_definitions(-D_CRT_SECURE_NO_DEPRECATE)